Slow Admin Site performance

Incident Report for FieldClock

Resolved

It looks like some of our fun new features had larger-than-forecast performance needs. We are increasing our server fleet to accomodate. Should be smooth from here but, as always, we'll keep an eye on things.
Posted Mar 14, 2025 - 16:22 PDT

Investigating

The Admin Site is loading slower than it should. We are investigating the issue.
Posted Mar 14, 2025 - 14:57 PDT
This incident affected: Admin Site.