Elevated error rates from API

Incident Report for FieldClock

Postmortem

One of our autoscaling groups controlling the API fleet had a misconfiguration that caused targets to drain and not replenish. This resulted in api.fieldclock.com returning “502” errors as the remaining servers became overloaded. The errant configuration was identified and corrected and full service was restored in minutes.

Posted Jan 13, 2026 - 08:46 PST

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 06:43 PST

Monitoring

Issue resolved! We're keeping an eye on the situation and will post details shortly.
Posted Jan 13, 2026 - 06:02 PST

Investigating

Many requests to FieldClock API are receiving "502 bad gateway" errors. We are looking into this. Mobile apps continue to work in offline mode but Admin Site and other apps that depend on API are receiving elevated error rates.
Posted Jan 13, 2026 - 05:59 PST
This incident affected: Admin Site, Employee Portal, and API.