FieldClock apps temporarily not available in Google Play
Incident Report for FieldClock
Resolved
Good news! Our appeal has been successful and both apps will be back in Play Store shortly.
Posted Sep 28, 2020 - 07:54 PDT
Monitoring
Google flagged our apps as "repetitive" as the FieldClock app and Kiosk app share some similarities. As a result, they are currently unavailable for new installs from Google Play. This should not affect any devices that already have FieldClock or Kiosk installed.

We have filed an appeal with Google and are awaiting their response. In the mean time, if your organization uses Mobile Device Management (MDM) software to manager your devices you can contact our Support team for a direct link to download the APK for either app.

For more information about MDM software, please check out this article: https://support.fieldclockapp.com/hc/en-us/articles/360037782131-Can-my-phones-be-locked-down-to-only-run-FieldClock-
Posted Sep 23, 2020 - 15:55 PDT
This incident affected: FieldClock (Android) and Kiosk (Android).